SetShape Method


Builds the type shape from the supplied collection of Geometry objects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2015

Syntax

C#
public void SetShape(
	IList<GeometryObject> pGeomArr
)
Visual Basic
Public Sub SetShape ( _
	pGeomArr As IList(Of GeometryObject) _
)
Visual C++
public:
void SetShape(
	IList<GeometryObject^>^ pGeomArr
)

Parameters

pGeomArr
Type: System.Collections.Generic IList GeometryObject
Shape of this object expressed as a collection of Geometry objects. These will be copied. Shape and Category should be consistent: geometry supplied as shape should be valid for the Category the type object is associated with.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException At least one member of pGeomArr does not satisfy DirectShapeType validation criteria.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also