Intent Property


The intent of the import.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public IFCImportIntent Intent { get; set; }
Visual Basic
Public Property Intent As IFCImportIntent
	Get
	Set
Visual C++
public:
property IFCImportIntent Intent {
	IFCImportIntent get ();
	void set (IFCImportIntent value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also