Determines the diameter of the wire.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
The value should be positive and less than 12 inches/300 mm.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | When setting this property: The given value for wireDiameter is not a number |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | When setting this property: The wire diameter wireDiameter is negative or greater than 12 inches/300 mm. |
Autodesk.Revit.Exceptions DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |