Checks an ExternalFileReference to see if it is properly created.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- data
- Type: Autodesk.Revit.DB ExternalFileReference
The ExternalFileReference to be checked
Remarks
The following restrictions exist:
- PathType.Server is only valid for ExternalFileReferences of type ExternalFileReferenceType.RevitLink
- PathType.Content is only valid for ExternalFileReferences of type ExternalFileReferenceType.KeynoteTable, ExternalFileReferenceType.AssemblyCodeTable or ExternalFileReferenceType.Decal
- Keynote tables, assembly code tables and Decals (ExternalFileReferenceType.KeynoteTable, ExternalFileReferenceType.AssemblyCodeTable and ExternalFileReferenceType.Decal) may only be LinkedFileStatus.Loaded or LinkedFileStatus.NotFound.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |