Validates if the straight can be split into two at the passed in point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document.
- partId
- Type: Autodesk.Revit.DB ElementId
Id of the straight to split.
- position
- Type: Autodesk.Revit.DB XYZ
The position to split in the straight.
Return Value
Returns true if valid otherwise false if the straight cannot be split.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |