Autodesk.Revit.DB.Architecture Namespace


Classes

Class Description
Public class BuildingPad
Represents a BuildingPad element.
Public class ContinuousRail
Represents a continuous rail element in Autodesk Revit. Type Data Misc Data Path and Profile Data
Public class ContinuousRailType
A type element containing the properties of a continuous rail.
Public class CutMarkType
An object represents the cut mark type in Autodesk Revit.
Public class Fascia
An object that represents a fascia within the Autodesk Revit project.
Public class FasciaType
An object that represents the fascia type in Autodesk Revit.
Public class Gutter
An object that represents a gutter within the Autodesk Revit project.
Public class GutterType
An object that represents the gutter type in Autodesk Revit.
Public class HandRail
Represents a hand rail element in Autodesk Revit.
Public class HandRailType
A rail type object that is used in the generation of hand rail.
Public class Railing
Represents a railing element in Autodesk Revit.
Public class RailingType
A railing type object that is used in the generation of railing.
Public class Room
Provides access to the room topology in Autodesk Revit.
Public class RoomFilter
A filter used to match rooms.
Public class RoomTag
Provides access to the room tag in Autodesk Revit.
Public class RoomTagFilter
A filter used to match room tags.
Public class RoomTagType
An object that represents a Room Tag type.
Public class SiteSubRegion
Represents a proxy class exposing the interfaces needed to access details of a subregion.
Public class Stairs
Represents a stairs element in Autodesk Revit.
Public class StairsComponentConnection
Represents information about a connection among stairs components(run to landing).
Public class StairsLanding
An object that represents a stairs landing in Autodesk Revit.
Public class StairsLandingType
Represents a stairs landing type in Autodesk Revit.
Public class StairsPath
An object that represents the stairs path.
Public class StairsPathType
An object represents the stairs path type.
Public class StairsRun
Represents a stairs run element in Autodesk Revit.
Public class StairsRunType
A stairs run type object that is used in the generation of stairs run.
Public class StairsType
A type element containing the properties for a component-based stair.
Public class TopographyEditScope
A TopographyEditScope allows an application to create and maintain an editing session for a TopographySurface.
Public class TopographySurface
Represents a TopographySurface element.
Public class TopRail
Represents a top rail element in Autodesk Revit.
Public class TopRailType
A rail type object that is used in the generation of top rail.

Enumerations

Enumeration Description
Public enumeration CutLineType
The available line types for a stairs cut line.
Public enumeration CutMarkSymbol
The available shapes for the cut mark symbol.
Public enumeration HandRailPosition
The position of the hand rail.
Public enumeration RailAngledJoinOption
The angled joins of the rails.
Public enumeration RailConnectionOption
The connections between rails.
Public enumeration RailExtensionStyle
The extension style of the rail.
Public enumeration RailIndex
The continuous rail position index.
Public enumeration RailingHeightCorrectionOption
Railing height correction option.
Public enumeration RailingPathCurveJoinOption
The join type of the railing path.
Public enumeration RailingPlacementPosition
Railing placement position.
Public enumeration RailingSlopeOption
The option determines the slope of the railing.
Public enumeration RailJoinOption
The join type of the system rails.
Public enumeration RailSupportJustification
The justification of the rail supports.
Public enumeration RailSupportsLayout
The layout of the rail supports.
Public enumeration RailTagentJoinOption
The tangent joins of the rails.
Public enumeration RailTransitionOption
The transition type of the continuous rail.
Public enumeration RailTypeDefaultJoinOption
The default join type of the rail.
Public enumeration RiserToTreadConnectionOption
Represents the connection style of the riser and tread in relation to each other.
Public enumeration SketchedCurveSlopeOption
The option determines the slop of the sketched run/landing.
Public enumeration StairsComponentConnectionEndType
The end type identifying the connection type among stairs runs and landings.
Public enumeration StairsConstructionMethod
Represents the construction method of the stairs.
Public enumeration StairsEndConnectionType
The join style between a run and landing.
Public enumeration StairsEndNotchOption
The style of notch width for the stairs.
Public enumeration StairsNumberSystemReferenceOption
The reference types permitted for a number system to refer to the geometry of a stairs run.
Public enumeration StairsPathDirection
The direction style of stairs path.
Public enumeration StairsPathLineShapeAtCorner
The options for the line shape of a stairs path at a corner.
Public enumeration StairsRunJustification
The position of the run relative to the Up-direction path used to create the run.
Public enumeration StairsRunStyle
The shape of a run. Different shape has different ways of manipulation.
Public enumeration StairsSupportTopsideSurfaceType
The style of the topside surface of the support.
Public enumeration StairsTextOrientation
The options to be used when orienting text annotations relative to stairs.
Public enumeration StairsUndersideSurfaceStyle
The style of the underside surface of the run.
Public enumeration StairsWinderStyle
The calculation method for the layout of the winder run steps.
Public enumeration TreadNosingPosition
Represents on which edges of the nosing to apply the nosing profile.
Public enumeration WinderPathResult
Flag indicates whether curves are valid to use as base lines for winder path.