IsUpdaterRegistered Method (UpdaterId)


Checks whether updater with the given id is registered

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public static bool IsUpdaterRegistered(
	UpdaterId id
)
Visual Basic
Public Shared Function IsUpdaterRegistered ( _
	id As UpdaterId _
) As Boolean
Visual C++
public:
static bool IsUpdaterRegistered(
	UpdaterId^ id
)

Parameters

id
Type: Autodesk.Revit.DB UpdaterId
Id of the updater being tested.

Return Value

Returns true if the updater is registered.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also