Enables worksharing in the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- worksetNameGridLevel
- Type: System String
Name of workset for grids and levels.
- worksetName
- Type: System String
Name of workset for all other elements.
Remarks
The document's Undo history will be cleared by this command. As a result, this command and others executed before it cannot be undone.
All transaction phases (e.g. transactions transaction groups and sub-transaction) that were explicitly started must be finished prior to calling this method.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | worksetNameGridLevel is an empty string. -or- worksetName is an empty string. -or- worksetNameGridLevel cannot include prohibited characters. -or- worksetName cannot include prohibited characters. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ForbiddenForDynamicUpdateException | This method may not be called during dynamic update. |
Autodesk.Revit.Exceptions InvalidOperationException | The document does not allow worksharing to be enabled. -or- This Document has is in an edit mode or is in family mode. -or- This Document is a workshared document. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method. |
Autodesk.Revit.Exceptions OperationCanceledException | Enabling worksharing was cancelled. |