IExportContext Interface


An interface that is used in custom export to process a Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2014

Syntax

C#
public interface IExportContext
Visual Basic
Public Interface IExportContext
Visual C++
public interface class IExportContext

Remarks

An instance of a class that implements this interface is passed in as a parameter of the CustomExporter constructor. The methods of the context are then called at times of exporting entities of the model.

This is a base class for two other interfaces derived from it: [!:Autodesk::Revit::DB::IPhotoRenderContext] and [!:Autodesk::Revit::DB::IModelExportContext] which are both new since Revit 2016. This base class contains methods that are common to both the leaf interfaces. Although it is still possible to use classes deriving directly from this base interface (for backward compatibility), future applications should implement the new leaf interfaces only.

See Also