Creates a new ParameterFilterElement in the given document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDocument
- Type: Autodesk.Revit.DB Document
The document in which to create the ParameterFilterElement.
- name
- Type: System String
The user-visible name for the new ParameterFilterElement.
- categories
- Type: System.Collections.Generic ICollection ElementId
The categories for the new ParameterFilterElement.
- rules
- Type: System.Collections.Generic IList FilterRule
The rules for the new ParameterFilterElement.
Return Value
A pointer to the new ParameterFilterElement.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | name is an empty string or contains only whitespace. -or- name cannot include prohibited characters. -or- The given value for name is already in use as a filter element name. -or- One of the given rules refers to a parameter that does not apply to this filter's categories. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |