GetFoundationType Method


Gets an object that represents the type of the foundation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2016

Syntax

C#
[ObsoleteAttribute("This method is obsolete in Revit 2017. Use GetTypeId() instead.")]
public WallFoundationType GetFoundationType()
Visual Basic
<ObsoleteAttribute("This method is obsolete in Revit 2017. Use GetTypeId() instead.")> _
Public Function GetFoundationType As WallFoundationType
Visual C++
[ObsoleteAttribute(L"This method is obsolete in Revit 2017. Use GetTypeId() instead.")]
public:
WallFoundationType^ GetFoundationType()

Remarks

The Wall Foundation type can be used to access the multi layered structure of a foundation.

See Also