GetPointCloudOverrideSettings Method (ElementId)


Gets override settings assigned to the whole PointCloudInstance element.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2014

Syntax

C#
[ObsoleteAttribute("this method will be obsoleted from 2017, please use GetPointCloudScanOverrideSettings instead.")]
public PointCloudOverrideSettings GetPointCloudOverrideSettings(
	ElementId elementId
)
Visual Basic
<ObsoleteAttribute("this method will be obsoleted from 2017, please use GetPointCloudScanOverrideSettings instead.")> _
Public Function GetPointCloudOverrideSettings ( _
	elementId As ElementId _
) As PointCloudOverrideSettings
Visual C++
[ObsoleteAttribute(L"this method will be obsoleted from 2017, please use GetPointCloudScanOverrideSettings instead.")]
public:
PointCloudOverrideSettings^ GetPointCloudOverrideSettings(
	ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DB ElementId
Id of the overridden element.

Return Value

The override settings assigned to the element, if present, or a default override settings if nothing was found.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also