Class Property


The schedule type of the pipe type.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)

Syntax

C#
[ObsoleteAttribute("This property is obsolete in Revit 2017. Please use Pipe.PipeSegment.ScheduleTypeId instead.")]
public PipeScheduleType Class { get; }
Visual Basic
<ObsoleteAttribute("This property is obsolete in Revit 2017. Please use Pipe.PipeSegment.ScheduleTypeId instead.")> _
Public ReadOnly Property Class As PipeScheduleType
	Get
Visual C++
[ObsoleteAttribute(L"This property is obsolete in Revit 2017. Please use Pipe.PipeSegment.ScheduleTypeId instead.")]
public:
property PipeScheduleType^ Class {
	PipeScheduleType^ get ();
}

See Also