GetLocalPathForOpen Method


Implement this method to specify the local path from where a copy of a Revit link external resource can be opened for modification without interfering with its use as a link in other open documents.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
string GetLocalPathForOpen(
	ExternalResourceReference desiredResource
)
Visual Basic
Function GetLocalPathForOpen ( _
	desiredResource As ExternalResourceReference _
) As String
Visual C++
String^ GetLocalPathForOpen(
	ExternalResourceReference^ desiredResource
)

Parameters

desiredResource
Type: Autodesk.Revit.DB ExternalResourceReference
The ExternalResourceReference that needs to be opened for modification by Revit.

Return Value

The local path from where Revit can open the linked file as its own top-level document.

See Also