GetCompoundStructure Method


Returns an object that represents the compound structure of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public CompoundStructure GetCompoundStructure()
Visual Basic
Public Function GetCompoundStructure As CompoundStructure
Visual C++
public:
CompoundStructure^ GetCompoundStructure()

Remarks

A copy of the compound structure is returned and changes made to it will not apply to the type until SetCompoundStructure is called. From this object the layers of a compound structure can be accessed. If the element does not have a compound structure then this method will return a null reference ( Nothing in Visual Basic) .

See Also