PipeSegment Class


The PipeSegment class represents an instance of pipe segment which has the design data for routing preference.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public class PipeSegment : Segment
Visual Basic
Public Class PipeSegment _
	Inherits Segment
Visual C++
public ref class PipeSegment : public Segment

Inheritance Hierarchy

See Also