Indicates if reference is acceptable as a "Target" for Manual Analytical Adjustment.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- target
- Type: Autodesk.Revit.DB Reference
Target reference.
- source
- Type: Autodesk.Revit.DB Reference
Source reference. This is necessary to avoid illegal conditions. For instance if Element A is manually adjusted against Element B, Element B cannot in general be adjusted against Element A.
- direction
- Type: Autodesk.Revit.DB.Structure AnalyticalDirection
Direction in which source Element can be adjusted against target Element.
Return Value
True if reference can be used, false otherwise.Remarks
This method is useful for determining if a reference is acceptable for a target. In other words, if the reference identifies an Analytical Model portion that can be adjusted against.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | This AnalyticalModel does not support Manual Analytical Adjustment. |