Returns the parameter for a given filter rule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- rule
- Type: Autodesk.Revit.DB FilterRule
The rule to query.
Return Value
The identifier of the rule's parameter.Remarks
If the given rule is a FilterInverseRule, then getRuleParameter will return the parameter of its inner rule.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given rule is not parameter-based. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |