An enumerated type listing AssetProperty Types in Revit.
Namespace: Autodesk.Revit.Utility
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
APT_Unknown | An unknown or unspecified property type. |
APT_Properties | Represents Properties. The corresponding AssetProperty sub class is AssetProperties. |
APT_Boolean | Represents property Boolean. The corresponding AssetProperty sub class is AssetPropertyBoolean. |
APT_Enum | Represents property Enum. The corresponding AssetProperty sub class is AssetPropertyEnum. |
APT_Integer | Represents property Integer. The corresponding AssetProperty sub class is AssetPropertyInteger. |
APT_Float | Represents property Float. The corresponding AssetProperty sub class is AssetPropertyFloat. |
APT_Double | Represents property Double. The corresponding AssetProperty sub class is AssetPropertyDouble. |
APT_DoubleArray2d | Represents property 2d Double array. The corresponding AssetProperty sub class is AssetPropertyDoubleArray2d. |
APT_DoubleArray3d | Represents property 3d Double array. The corresponding AssetProperty sub class is AssetPropertyDoubleArray3d. |
APT_DoubleArray4d | Represents property 4d Double array. The corresponding AssetProperty sub class is AssetPropertyDoubleArray4d. |
APT_Double44 | Represents property 4x4 Double matrix. The corresponding AssetProperty sub class is AssetPropertyDoubleMatrix44. |
APT_String | Represents property String. The corresponding AssetProperty sub class is AssetPropertyString. |
APT_Time | Represents property Time. The corresponding AssetProperty sub class is AssetPropertyTime. |
APT_Distance | Represents property Distance. The corresponding AssetProperty sub class is AssetPropertyDistance. |
APT_Asset | Represents property Asset. The corresponding AssetProperty sub class is Asset. |
APT_Reference | Represents property Reference. The corresponding AssetProperty sub class is AssetPropertyReference. |
APT_Int64 | Represents property Int64. The corresponding AssetProperty sub class is AssetPropertyInt64. |
APT_UInt64 | Represents property unsigned Int64. The corresponding AssetProperty sub class is AssetPropertyUInt64. |
APT_List | Represents property List. The corresponding AssetProperty sub class is AssetPropertyList. |
APT_FloatArray | Represents property Float array. The corresponding AssetProperty sub class is AssetPropertyFloatArray. |