DisconnectPanel Method


Disconnect the panel for the Electrical System.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public void DisconnectPanel()
Visual Basic
Public Sub DisconnectPanel
Visual C++
public:
void DisconnectPanel()

Remarks

If successful, the system will disconnect this panel. Otherwise the exception will be thrown. This method will only function with the Autodesk Revit MEP application.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when the panel parameter Value is a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions InvalidOperationException Thrown when the panel cannot be disconnected for the electrical system.

See Also