Distance Property


Distance to the next fabric wire item

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2017

Syntax

C#
public double Distance { get; set; }
Visual Basic
Public Property Distance As Double
	Get
	Set
Visual C++
public:
property double Distance {
	double get ();
	void set (double value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException When setting this property: The given value for distance is not a number
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: The given value for distance must be greater than 0 and no more than 30000 feet.
Autodesk.Revit.Exceptions DisabledDisciplineException When setting this property: None of the following disciplines is enabled: Structural.

See Also