Checks that the parameters of the given rules are valid for this filter's categories.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- rules
- Type: System.Collections.Generic IList FilterRule
The rules to check.
Return Value
True if all the parameters of the given rules are valid for this filter, otherwise false.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |