Gets the local coordinate system (LCS) reflects analytical model orientation at the specified point.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- point
- Type: Autodesk.Revit.DB XYZ
The point on the analytical model stick element.
Return Value
Transformation matrix.- x - longitudinal axis,
- y - transversal, section - horizontal, strong axis,
- z - transversal, section - vertical, weak axis,
- origin - base point of LCS.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The point does not lie on the element. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |