GetRegisteredUpdaterInfos Method (Document)


Returns information about all updaters applicable to the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public static IList<UpdaterInfo> GetRegisteredUpdaterInfos(
	Document document
)
Visual Basic
Public Shared Function GetRegisteredUpdaterInfos ( _
	document As Document _
) As IList(Of UpdaterInfo)
Visual C++
public:
static IList<UpdaterInfo^>^ GetRegisteredUpdaterInfos(
	Document^ document
)

Parameters

document
Type: Autodesk.Revit.DB Document
The document to which sought updaters are applicable to.

Return Value

List of UpdaterInfo structures

Remarks

The list of data includes information about all updaters explicitly registered for the document as well as information about all application-wide registered updaters (which are applicable to all documents).

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also