IsDone Method


Identifies if the iteration has completed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public virtual bool IsDone()
Visual Basic
Public Overridable Function IsDone As Boolean
Visual C++
public:
virtual bool IsDone()

Return Value

True if the iteration has no more matching elements. False if there are more element ids to be iterated.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException The FilteredElementCollector that yielded this iterator has been reset by another operation. No further iteration is permitted with this iterator.

See Also