SetFaceReference Method


Change the face reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public void SetFaceReference(
	Reference reference
)
Visual Basic
Public Sub SetFaceReference ( _
	reference As Reference _
)
Visual C++
public:
void SetFaceReference(
	Reference^ reference
)

Parameters

reference
Type: Autodesk.Revit.DB Reference

Remarks

The referenced element may be any model element, including FamilyInstance or FormElement. The reference must be of type ElementReferenceType.REFERENCE_TYPE_SURFACE, and the surface must be of type Plane . The Reference's UVPoint property is ignored.

See Also