ServerSupportsKeynotes Method


Checks that the server referenced by the given ExternalResourceReference supports KeynoteTable data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public static bool ServerSupportsKeynotes(
	ExternalResourceReference extRef
)
Visual Basic
Public Shared Function ServerSupportsKeynotes ( _
	extRef As ExternalResourceReference _
) As Boolean
Visual C++
public:
static bool ServerSupportsKeynotes(
	ExternalResourceReference^ extRef
)

Parameters

extRef
Type: Autodesk.Revit.DB ExternalResourceReference
The ExternalResourceReference to check.

Return Value

True if the ExternalResourceReference refers to a server that supports keynotes. False otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also