Retrieves other Element Ids that this Element is Auto-detecting against.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- direction
- Type: Autodesk.Revit.DB.Structure AnalyticalDirection
Direction in which Analytical Auto-detect is being done.
Return Value
A set of Element Ids against which this Element is Auto-detecting. The set may be empty if this Element is not Auto-detecting against anything.Remarks
An empty set is a valid return value. It just means that this Element is not Auto-detecting against any other Elements in the given direction.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | direction is invalid for Analytical Auto-detect. |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |