SpatialElementCalculationLocation Class


The Spatial Element Calculation Location is used to specify the room/space where an element should be considered as placed.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public class SpatialElementCalculationLocation : Element
Visual Basic
Public Class SpatialElementCalculationLocation _
	Inherits Element
Visual C++
public ref class SpatialElementCalculationLocation : public Element

Remarks

It currently has two types of calculation location: SpatialElementCalculationPoint and SpatialElementFromToCalculationPoints A user can turn on the Spatial Element Calculation Location in the family editor by setting the family's ROOM_CALCULATION_POINT parameter. A user can move the location of the Spatial Element Calculation Location in the family editor. A user can visually verify the location of the Spatial Element Calculation Point by selecting the fixture in the project.

Inheritance Hierarchy

See Also