GetFirstProfileCurve Method


Returns a copy of the first profile curve if it is set. If a point was used to define the first profile, this function will return NULL.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2017

Syntax

C#
public Curve GetFirstProfileCurve()
Visual Basic
Public Function GetFirstProfileCurve As Curve
Visual C++
public:
Curve^ GetFirstProfileCurve()

Return Value

A copy of the first profile curve, if it exists.

See Also