GetOpeningData Method


Gets the openings data from the element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2014

Syntax

C#
[ObsoleteAttribute("This function is deprecated in Revit 2017.  Use GetOpeningData that uses a Transform instead.")]
public static IList<IFCOpeningData> GetOpeningData(
	ExporterIFC exporterIFC,
	Element element,
	Plane plane,
	IFCRange range
)
Visual Basic
<ObsoleteAttribute("This function is deprecated in Revit 2017.  Use GetOpeningData that uses a Transform instead.")> _
Public Shared Function GetOpeningData ( _
	exporterIFC As ExporterIFC, _
	element As Element, _
	plane As Plane, _
	range As IFCRange _
) As IList(Of IFCOpeningData)
Visual C++
[ObsoleteAttribute(L"This function is deprecated in Revit 2017.  Use GetOpeningData that uses a Transform instead.")]
public:
static IList<IFCOpeningData^>^ GetOpeningData(
	ExporterIFC^ exporterIFC, 
	Element^ element, 
	Plane^ plane, 
	IFCRange^ range
)

Parameters

exporterIFC
Type: Autodesk.Revit.DB.IFC ExporterIFC
The exporter.
element
Type: Autodesk.Revit.DB Element
The element.
plane
Type: Autodesk.Revit.DB Plane
The plane for the extrusion.
range
Type: Autodesk.Revit.DB.IFC IFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire element is used.

Return Value

The opening data.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also