CreateCurveGeometryInfo Method


Creates a new container object which holds IfcCurve handles processed from a Revit geometry object.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2012

Syntax

C#
[ObsoleteAttribute("This function is deprecated in Rvit 2017. Use CreateCurveGeometryInfo(ExporterIFC, Transform, XYZ, bool) instead.")]
public static IFCGeometryInfo CreateCurveGeometryInfo(
	ExporterIFC ExporterIFC,
	Plane plane,
	XYZ projectionDir,
	bool planViewOnly
)
Visual Basic
<ObsoleteAttribute("This function is deprecated in Rvit 2017. Use CreateCurveGeometryInfo(ExporterIFC, Transform, XYZ, bool) instead.")> _
Public Shared Function CreateCurveGeometryInfo ( _
	ExporterIFC As ExporterIFC, _
	plane As Plane, _
	projectionDir As XYZ, _
	planViewOnly As Boolean _
) As IFCGeometryInfo
Visual C++
[ObsoleteAttribute(L"This function is deprecated in Rvit 2017. Use CreateCurveGeometryInfo(ExporterIFC, Transform, XYZ, bool) instead.")]
public:
static IFCGeometryInfo^ CreateCurveGeometryInfo(
	ExporterIFC^ ExporterIFC, 
	Plane^ plane, 
	XYZ^ projectionDir, 
	bool planViewOnly
)

Parameters

ExporterIFC
Type: Autodesk.Revit.DB.IFC ExporterIFC
The exporter.
plane
Type: Autodesk.Revit.DB Plane
The plane in which the curve handles must lie.
projectionDir
Type: Autodesk.Revit.DB XYZ
The normal vector to the input plane.
planViewOnly
Type: System Boolean
True to match curves with plan view visibility only, false to match curves regardless of their plan view visibility.

Return Value

The new geometry info container.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also