IsValidPlaneReference Method


Check whether a geometry reference corresponds to a referenceable plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public static bool IsValidPlaneReference(
	Document doc,
	Reference planeReference
)
Visual Basic
Public Shared Function IsValidPlaneReference ( _
	doc As Document, _
	planeReference As Reference _
) As Boolean
Visual C++
public:
static bool IsValidPlaneReference(
	Document^ doc, 
	Reference^ planeReference
)

Parameters

doc
Type: Autodesk.Revit.DB Document
planeReference
Type: Autodesk.Revit.DB Reference

Remarks

Valid plane references include: planar faces of solids; the PlaneReference properties of Level and SketchPlane ; the Reference property of ReferencePlane .

See Also