Form Class


An object that represents a Form within the Autodesk Revit Massing Family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class Form : GenericForm
Visual Basic
Public Class Form _
	Inherits GenericForm
Visual C++
public ref class Form : public GenericForm

Remarks

For any reference returned from a Form method, its GeometryObject will become invalid after a form modification method, e.g. MoveSubElement. Call the method on the Form object to retrieve the new reference if it is needed after the modification.

Inheritance Hierarchy

See Also