HasPhases Method


Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013

Syntax

C#
public bool HasPhases()
Visual Basic
Public Function HasPhases As Boolean
Visual C++
public:
bool HasPhases()

Return Value

True if this Element has the properties CreatedPhaseId and DemolishedPhaseId, false otherwise.

Remarks

Acts as a validator for setting the properties CreatedPhaseId and DemolishedPhaseId.

See Also