LeaderAtachement Enumeration


Supported kinds of vertical attachments of a leader to a text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016
Since: 2016

Syntax

C#
public enum LeaderAtachement
Visual Basic
Public Enumeration LeaderAtachement
Visual C++
public enum class LeaderAtachement

Members

Member name Description
TopLine Leaders are attached at the position of the top (first) line of the text box, and, unless the text's border is visible, the leader's shoulder line extends all the way to the text, minus the current value of text border offset.
Midpoint Leaders are aligned vertically with the midpoint of the text box and their shoulder line always ends at the box' border regardless of whether the border is visible on not.
BottomLine Leaders are attached at the position of the bottom (last) line of the text box, and, unless the text's border is visible, the leader's shoulder line extends all the way to the text, minus the current value of text border offset.

See Also