PointOnFace Class


Define a ReferencePoint relative to a Face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class PointOnFace : PointElementReference
Visual Basic
Public Class PointOnFace _
	Inherits PointElementReference
Visual C++
public ref class PointOnFace : public PointElementReference

Remarks

A ReferencePoint on a Face has its X and Y basis vectors parallel to the Face, but is free to rotate around its Z basis vector. It must lie on the face (unlike PointOnPlane).

Inheritance Hierarchy

See Also