DialogBoxShowingEventArgs Class


The base class for the event arguments used by the DialogBoxShowing event.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2010

Syntax

C#
public class DialogBoxShowingEventArgs : RevitAPIPreEventArgs
Visual Basic
Public Class DialogBoxShowingEventArgs _
	Inherits RevitAPIPreEventArgs
Visual C++
public ref class DialogBoxShowingEventArgs : public RevitAPIPreEventArgs

Remarks

The actual type of the event arguments will be different depending upon the type of dialog shown. When the application receives this object, a dialog is to be displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.

Inheritance Hierarchy

See Also