CurveLoopsProfile Class


Represents a curve loop based profile for sweep or swept blend elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public class CurveLoopsProfile : SweepProfile
Visual Basic
Public Class CurveLoopsProfile _
	Inherits SweepProfile
Visual C++
public ref class CurveLoopsProfile : public SweepProfile

Remarks

Use objects of this type in methods as NewSweep() and NewSweptBlend() in FamilyItemFactory to create the profile.

Inheritance Hierarchy

See Also