The various types of handles on a Rebar instance that can be joined to References
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since:
2014
Since:
2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
Undefined | represents an undefined handle. if this value is returned, then the handle cannot find it's type |
RebarPlane | Handle controlling the location of the Rebar's primary plane. Drives location of the entire Rebar along the direction of its normal. |
StartOfBar | Handle controlling start point of the Rebar. |
EndOfBar | Handle controlling end point of the Rebar. |
Edge | Handle controlling location of a single edge segment of the Rebar. Drives the edge in the direction perpendicular to the edge and in the Rebar's primary plane. |
OutOfPlaneExtent | Handle controlling the extent of a three-dimensional Rebar out of its primary plane. This includes the length of a Rebar Set, the out-of-plane length of a multi-planar Rebar, and the length of a spiral Rebar. |
CustomHandle | Custom handle used in API constraints. The handle itself and the behavior of this type of handle is defined in the API (see IRebarUpdateServer ). This handle defines a symbolic part of the rebar and is not tied to a specific segment or part of the rebar. Handles that represent the start and end of a bar should not be of this type. |