SuperComponent Property


Property to get the super component of current family instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
public Element SuperComponent { get; }
Visual Basic
Public ReadOnly Property SuperComponent As Element
	Get
Visual C++
public:
property Element^ SuperComponent {
	Element^ get ();
}

Remarks

When the FamilyInstance has no super component, it returns a null reference ( Nothing in Visual Basic)

See Also