Restores an unpinned stairs element back into the group of stairs governed by level height.
Namespace:
Autodesk.Revit.DB.Architecture
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since:
2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- levelId
-
Type:
Autodesk.Revit.DB
ElementId
The base level id. If the level id belongs to the base level of an individual pinned stairs, it returns the stairs id directly.
Return Value
The stairs element which the pinned story belongs to.Remarks
If the level height of current story can be found among other stories, the stair will be added back into the group;
Otherwise only the status will be changed to "pinned".
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | There is no stairs instance at the given base levelId. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |