MEPAnalyticalConnection Class


Represents an analytical element that connects mechanical equipment to piping network.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public class MEPAnalyticalConnection : MEPCurve
Visual Basic
Public Class MEPAnalyticalConnection _
	Inherits MEPCurve
Visual C++
public ref class MEPAnalyticalConnection : public MEPCurve

Remarks

The analytical connection takes mechanical equipment into account of network flow/pressure analysis. The connection remains the same even if the mechanical equipment moves and rotates. It enables a fast establishment of piping network to analyze the flow and pressure, especially at the early stage of the design process.

Inheritance Hierarchy

See Also