FlowState Property


The flowState of the pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014

Syntax

C#
public PipeFlowState FlowState { get; set; }
Visual Basic
Public Property FlowState As PipeFlowState
	Get
	Set
Visual C++
public:
property PipeFlowState FlowState {
	PipeFlowState get ();
	void set (PipeFlowState value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also