Autodesk.Revit.ApplicationServices Namespace


Classes

Class Description
Public class Application
Represents the Autodesk Revit Application, providing access to documents, options and other application wide data and settings.
Public class ControlledApplication
Represents the Autodesk Revit Application with no access to documents. It provides options and other application wide data and settings for external applications OnStartup/OnShutdown.

Enumerations

Enumeration Description
Public enumeration LanguageType
An enumerated type containing the supported Revit product languages.
Public enumeration ProductType
An enumerated type containing the possible Revit product types.