Surface Class


A mathematical representation of a surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since: 2016

Syntax

C#
public class Surface : IDisposable
Visual Basic
Public Class Surface _
	Implements IDisposable
Visual C++
public ref class Surface : IDisposable

Remarks

This geometric object is not bounded by edges or edge loops. A bounded surface obtained from a Revit element will be represented by a Face instead.

Inheritance Hierarchy

See Also