The type of middle supports used in the stair.
Namespace:
Autodesk.Revit.DB.Architecture
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since:
2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
invalidElementId if the stairs type has no middle support.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | When setting this property: supportType is not a valid middle support type. |
Autodesk.Revit.Exceptions ArgumentNullException | When setting this property: A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | When setting this property: The stairs type has no middle support so the data being set is not applicable. |