ForbiddenForDynamicUpdateException Class


The exception that is thrown when making or attempting to make changes that are forbidden during dynamic updates to the model.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)

Syntax

C#
[SerializableAttribute]
public class ForbiddenForDynamicUpdateException : InvalidOperationException
Visual Basic
<SerializableAttribute> _
Public Class ForbiddenForDynamicUpdateException _
	Inherits InvalidOperationException
Visual C++
[SerializableAttribute]
public ref class ForbiddenForDynamicUpdateException : public InvalidOperationException

Remarks

Modifications leading to a new mutual relationship between elements that did not depend on each other before are potentially not safe in work-set environment. This exception is thrown when an Updater either makes such modifications or attempts to call a method that will or may modify the model in such unsafe matter.

Inheritance Hierarchy

See Also