SetPressLossCalculationServerInfo Method


Set the MEPServerInfo of the current pipe pressure loss calculation server.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2012

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2018 and will be removed in the next version of Revit. Custom pipe pressure loss calculations will no longer be supported.")]
public void SetPressLossCalculationServerInfo(
	MEPCalculationServerInfo serverInfo
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2018 and will be removed in the next version of Revit. Custom pipe pressure loss calculations will no longer be supported.")> _
Public Sub SetPressLossCalculationServerInfo ( _
	serverInfo As MEPCalculationServerInfo _
)
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2018 and will be removed in the next version of Revit. Custom pipe pressure loss calculations will no longer be supported.")]
public:
void SetPressLossCalculationServerInfo(
	MEPCalculationServerInfo^ serverInfo
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also