Autodesk.Revit.DB.Visual Namespace


Classes

Class Description
Public class AdvancedLayered
Represents the properties of materials.
Public class AdvancedMetal
Represents the properties of materials.
Public class AdvancedOpaque
Represents the properties of materials.
Public class AdvancedTransparent
Represents the properties of materials.
Public class AdvancedWood
Represents the properties of materials.
Public class AppearanceAssetEditScope
A scope object that provides special access and limitations related to editing appearance assets and their related elements.
Public class Asset
Represents a connected property of material.
Public class AssetProperties
Represents a set of asset property(s).
Public class AssetProperty
Represents a property of material.
Public class AssetPropertyBoolean
Represents a property of material.
Public class AssetPropertyDistance
Represents a property of material.
Public class AssetPropertyDouble
Represents a property of material.
Public class AssetPropertyDoubleArray2d
Represents a property consisting of an array of double values.
Public class AssetPropertyDoubleArray3d
Represents a vector or point property.
Public class AssetPropertyDoubleArray4d
Represents a color property of material.
Public class AssetPropertyDoubleMatrix44
Represents a property consisting of an array of double values.
Public class AssetPropertyEnum
Represents a property of material.
Public class AssetPropertyFloat
Represents a property of material.
Public class AssetPropertyFloatArray
Represents a property consisting of an array of float values.
Public class AssetPropertyInt64
Represents a property of Int64 value.
Public class AssetPropertyInteger
Represents a property of material.
Public class AssetPropertyList
Represents a list of AssetProperty(s).
Public class AssetPropertyReference
Represents a connected property of material.
Public class AssetPropertyString
Represents a property of material.
Public class AssetPropertyTime
Represents a connected property of material.
Public class AssetPropertyUInt64
Represents a property of UInt64 value.
Public class AssetSet
Public class AssetSetIterator
Public class BumpMap
Represents the properties of materials.
Public class Ceramic
Represents the properties of materials.
Public class Checker
Represents the properties of materials.
Public class Concrete
Represents the properties of materials.
Public class Generic
Represents the properties of materials.
Public class Glazing
Represents the properties of materials.
Public class Gradient
Represents the properties of materials.
Public class Hardwood
Represents the properties of materials.
Public class Marble
Represents the properties of materials.
Public class MasonryCMU
Represents the properties of materials.
Public class Metal
Represents the properties of materials.
Public class MetallicPaint
Represents the properties of materials.
Public class Mirror
Represents the properties of materials.
Public class Noise
Represents the properties of materials.
Public class PlasticVinyl
Represents the properties of materials.
Public class SchemaCommon
Represents the properties of materials.
Public class SolidGlass
Represents the properties of materials.
Public class Speckle
Represents the properties of materials.
Public class Stone
Represents the properties of materials.
Public class Tile
Represents the properties of materials.
Public class UnifiedBitmap
Represents the properties of materials.
Public class WallPaint
Represents the properties of materials.
Public class Water
Represents the properties of materials.
Public class Wave
Represents the properties of materials.
Public class Wood
Represents the properties of materials.

Enumerations

Enumeration Description
Public enumeration AssetPropertyType
Enumerated type listing the type of asset property
Public enumeration AssetType
Enumerated asset types
Public enumeration BumpmapType
The enumerated type representing the permitted values for the asset property "BumpmapType" from the "BumpMap" schema.
Public enumeration CeramicApplicationType
The enumerated type representing the permitted values for the asset property "CeramicApplication" from the "Ceramic" schema.
Public enumeration CeramicBumpType
The enumerated type representing the permitted values for the asset property "CeramicBump" from the "Ceramic" schema.
Public enumeration CeramicPatternType
The enumerated type representing the permitted values for the asset property "CeramicPattern" from the "Ceramic" schema.
Public enumeration CeramicType
The enumerated type representing the permitted values for the asset property "CeramicType" from the "Ceramic" schema.
Public enumeration CommonSharedAssetType
The enumerated type representing the permitted values for the asset property "CommonSharedAsset" from the "Ceramic" schema.
Public enumeration ConcreteBrightmodeType
The enumerated type representing the permitted values for the asset property "ConcreteBrightmode" from the "Concrete" schema.
Public enumeration ConcreteFinishType
The enumerated type representing the permitted values for the asset property "ConcreteFinish" from the "Concrete" schema.
Public enumeration ConcreteSealantType
The enumerated type representing the permitted values for the asset property "ConcreteSealant" from the "Concrete" schema.
Public enumeration GlazingTransmittanceColorType
The enumerated type representing the permitted values for the asset property "GlazingTransmittanceColor" from the "Glazing" schema.
Public enumeration GradientInterpolationType
The enumerated type representing the permitted values for the asset property "GradientInterpolation" from the "Gradient" schema.
Public enumeration GradientNoiseType
The enumerated type representing the permitted values for the asset property "GradientNoise" from the "Gradient" schema.
Public enumeration GradientType
The enumerated type representing the permitted values for the asset property "GradientType" from the "Gradient" schema.
Public enumeration HardwoodApplicationType
The enumerated type representing the permitted values for the asset property "HardwoodApplication" from the "Hardwood" schema.
Public enumeration HardwoodFinishType
The enumerated type representing the permitted values for the asset property "HardwoodFinish" from the "Hardwood" schema.
Public enumeration HardwoodImperfectionsType
The enumerated type representing the permitted values for the asset property "HardwoodImperfections" from the "Hardwood" schema.
Public enumeration HardwoodTintEnabledType
The enumerated type representing the permitted values for the asset property "HardwoodTintEnabled" from the "Hardwood" schema.
Public enumeration LayeredNdfType
The enumerated type representing the permitted values for the asset property "LayeredNdfType" from the "PrismLayered" schema.
Public enumeration MasonryCMUApplicationType
The enumerated type representing the permitted values for the asset property "MasonryCMUApplication" from the "MasonryCMU" schema.
Public enumeration MasonryCMUPatternType
The enumerated type representing the permitted values for the asset property "MasonryCMUPattern" from the "MasonryCMU" schema.
Public enumeration MasonryCMUType
The enumerated type representing the permitted values for the asset property "MasonryCMUType" from the "MasonryCMU" schema.
Public enumeration MetalFinishType
The enumerated type representing the permitted values for the asset property "MetalFinish" from the "Metal" schema.
Public enumeration MetallicpaintFinishType
The enumerated type representing the permitted values for the asset property "MetallicpaintFinish" from the "MetallicPaint" schema.
Public enumeration MetallicpaintFlecksType
The enumerated type representing the permitted values for the asset property "MetallicpaintFlecks" from the "MetallicPaint" schema.
Public enumeration MetallicpaintPearlType
The enumerated type representing the permitted values for the asset property "MetallicpaintPearl" from the "MetallicPaint" schema.
Public enumeration MetallicpaintTopcoatType
The enumerated type representing the permitted values for the asset property "MetallicpaintTopcoat" from the "MetallicPaint" schema.
Public enumeration MetalPatternType
The enumerated type representing the permitted values for the asset property "MetalPattern" from the "Metal" schema.
Public enumeration MetalPerforationsType
The enumerated type representing the permitted values for the asset property "MetalPerforations" from the "Metal" schema.
Public enumeration MetalType
The enumerated type representing the permitted values for the asset property "MetalType" from the "Metal" schema.
Public enumeration NoiseType
The enumerated type representing the permitted values for the asset property "NoiseType" from the "Noise" schema.
Public enumeration PlasticvinylApplicationType
The enumerated type representing the permitted values for the asset property "PlasticvinylApplication" from the "PlasticVinyl" schema.
Public enumeration PlasticvinylBumpType
The enumerated type representing the permitted values for the asset property "PlasticvinylBump" from the "PlasticVinyl" schema.
Public enumeration PlasticvinylPatternType
The enumerated type representing the permitted values for the asset property "PlasticvinylPattern" from the "PlasticVinyl" schema.
Public enumeration PlasticvinylType
The enumerated type representing the permitted values for the asset property "PlasticvinylType" from the "PlasticVinyl" schema.
Public enumeration SolidglassBumpEnableType
The enumerated type representing the permitted values for the asset property "SolidglassBumpEnable" from the "SolidGlass" schema.
Public enumeration SolidglassTransmittanceType
The enumerated type representing the permitted values for the asset property "SolidglassTransmittance" from the "SolidGlass" schema.
Public enumeration StoneApplicationType
The enumerated type representing the permitted values for the asset property "StoneApplication" from the "Stone" schema.
Public enumeration StoneBumpType
The enumerated type representing the permitted values for the asset property "StoneBump" from the "Stone" schema.
Public enumeration StonePatternType
The enumerated type representing the permitted values for the asset property "StonePattern" from the "Stone" schema.
Public enumeration SurfaceNdfType
The enumerated type representing the permitted values for the asset property "SurfaceNdfType" from the "PrismLayered" schema.
Public enumeration TileBrickType
The enumerated type representing the permitted values for the asset property "TileBrickType" from the "Tile" schema.
Public enumeration WallpaintApplicationType
The enumerated type representing the permitted values for the asset property "WallpaintApplication" from the "WallPaint" schema.
Public enumeration WallpaintFinishType
The enumerated type representing the permitted values for the asset property "WallpaintFinish" from the "WallPaint" schema.
Public enumeration WaterTintEnableType
The enumerated type representing the permitted values for the asset property "WaterTintEnable" from the "Water" schema.
Public enumeration WaterType
The enumerated type representing the permitted values for the asset property "WaterType" from the "Water" schema.
Public enumeration WaveDistributionType
The enumerated type representing the permitted values for the asset property "WaveDistribution" from the "Wave" schema.
Public enumeration WoodPoreType
The enumerated type representing the permitted values for the asset property "WoodPoreType" from the "PrismWood" schema.